Az új Joomlához konfiguráltuk a szervereket

Többen jeleztétek, hogy az új Joomla verziók (1.7 és 2.5) egyes moduljai Suhosin hibát dobnak a szervereken.

A hiba oka, hogy a Joomla CMS rendszer fejlesztői úgy döntöttek, hogy a Nooku keretrendszert beleépítik a az új Joomlába, ennek a keretrendeszernek pedig szüksége van erre a szerver beállításra, amit most elvégeztünk:

A beállításra azért van szükség, mert a Nooku így illeszt be fájlokat. Azt még nem értem pontosan, erre miért is nem használható a standard PHP Include, és miért kell ilyen biztonsági “engedményeket” tenni a Suhosin-ban, ami arra való, hogy az oldalak biztonságosabbak legyenek, de  remélem a Joomla fejlesztői észreveszik a bakit, és javítanak.

Hozzászólás küldése

Kövess minket!